Вопрос

Мини-карточка не переносится вместе с пакетом

Здравствуйте, коллеги.

Помогите разобраться в следующей проблеме: переношу пакет со среды разработки в тест. Установка пакета - ОК. В пакете настроена мини-карточка Лида и Продукта на добавление записи. После установки на тест мини-карточка Лида работает как и должна, а мини-карточка Продукта - отсутствует. В настройках раздела Продукты в среде разработки Мини-карточка включена на добавление и настроена, а на тесте - не включена и не настроена.

Подскажите решение, плс.

Заранее благодарен.

У меня такой же вопрос

4 комментария

Добрый вечер.

Вероятно, проблема в том, что Вы не установили (если они есть в пакете) или не привязали к Вашему пакету скрипты привязки миникарточки.

Посмотрите в таблице SysModuleEdit есть поле MiniPageSchemaUId. Проверьте, заполнено ли оно для Вашего раздела на деве и на тесте.

Также для решения проблемы рекомендую изучить статью по добавлению миникарточки на Академии.

Если все данные внесены, тогда можете ещё попробовать сгенерировать исходный код, скомпилировать все приложение и очистить редис и кеш браузера.

Скорее всего, при переносе с системы на систему перенесли не всё: либо не прикрепили к пакету и не перенесли какую-то схему, либо данные из таблиц, которые задают связь между разделом и мини-карточкой. Попробуйте на работающей системе менять настройки мини-карточки (включать/выключать для раздела) и смотреть в профайлере, что меняется в базе при этом в таблицах разделов и системных настроек. Примеры SQL-запросов при создании мини-карточки есть в этой статье.

Проблема в том, что когда мастер автоматически генерирует привязки, он не проставляет в них флаг "Обязательно для обновления" и привязки ставятся только те, которых в другой среде ещё не было. Зайдите в привязки, проставьте вручную флаг "Обязательно для обновления" на все колонки кроме ключа и всё перенесётся.

Спасибо, уважаемые коллеги. Буду пробовать.

Войдите или зарегистрируйтесь, чтобы комментировать