Здравствуйте, сложилась такая ситуация: есть пользовательский пакет, в котором находятся детали, объекты, схемы для пользовательского раздела, необходимо перенести пользовательский пакет с одного сайта на другой.
Пакет я перенёс, установив его из SVN, а вот раздел сам не добавился. В связи с этим, возник вопрос, как мне добавить раздел? Есть ли вообще такая возможность? Сталкивался ли кто-нибудь с такой "проблемой". Заранее спасибо за ответ.

Нравится

5 комментариев

Добрый день.

Попробуйте настроить рабочее место.

"Адаменко Александр Викторович" написал:

Добрый день.

Попробуйте настроить рабочее место.


Пробовал, раздел не высвечивается в доступных

Попробуйте найти свой раздел в SysModule в базе (проверить есть ли он вообще в системе). Если нет, то как вариант можно через sql добавить его.

Здравствуйте, Антон.

После установки пакета из SVN необходимо выполнить следующие действия:

1. Сгенерировать для требующих генерации.
2. Компилировать все.
3. Выбрать элементы, структура которых менялась. Обновить для них структуру БД.
4. На вкладке Данные отобразить колонки Текст последней ошибки и Требует установки в БД. Установить выбранные элементы.
5. На вкладке SQL сценарии Установить выбранные элементы.

Более подробную информацию вы можете найти по следующей ссылке:

https://www.youtube.com/watch?v=DKVo4I5uTXA&feature=youtu.be (с 03:55:00).

"Мария Ватулина" написал:

Здравствуйте, Антон.

После установки пакета из SVN необходимо выполнить следующие действия:

1. Сгенерировать для требующих генерации.
2. Компилировать все.
3. Выбрать элементы, структура которых менялась. Обновить для них структуру БД.
4. На вкладке Данные отобразить колонки Текст последней ошибки и Требует установки в БД. Установить выбранные элементы.
5. На вкладке SQL сценарии Установить выбранные элементы.

Более подробную информацию вы можете найти по следующей ссылке:

https://www.youtube.com/watch?v=DKVo4I5uTXA&feature=youtu.be (с 03:55:00).

Спасибо большое, помогло

Показать все комментарии